User Tools

Site Tools


Minimum Required Outlook Versions

In order to connect to mailboxes in Office 365 Exchange Online using Outlook, you must have a version equal to or later than the ones listed below. Outlook 2007 and earlier for Windows and Entourage 2008 and earlier for Mac are not supported.

CDS recommends installing the latest service pack and security updates for your client software. For more information, please see this Microsoft article.

Windows Clients

  • Outlook 2010 SP2 with October 2015 PU (KB3085604) - 14.0.7160.5000 (pending review)
  • Outlook 2013 SP1 with December 2015 PU (KB3114349) - 15.0.4779.1001
  • Outlook 2016 with March 2016 PU (KB3114861) - 16.0.4351.1000

Mac Clients

  • Outlook for Mac 2011 with May 2015 PU (KB3048688) - 14.5.1
  • Outlook 2016 for Mac with July 2015 RTM (KB3074479) - 15.11.2